Cisco 3560、2960交換機配置

一、開機

 

1、如是新設備,Console線連接,用SecureCRT連接,連接屬性如下圖:

開機需跳過系統默認配置模式,進入手動配置模式。

2、進入用戶模式,系統提示符為 >,此模式只能查看統計信息,無配置功能。

3、用戶模式下,輸入 enable ,進入特權模式,系統提示符為 #。

 

二、一些常用設置

 

1、設置enable密碼

(config)#enable password XXX

2、設置主機名

(config)#hostname XXX

3、關閉http訪問

(config)#no ip http server? ? ? ? ? ? ? ? ? //關閉http

(config)#no ip http secure-server? ? ? //關閉https

使用下面命令設置WEB管理賬號密碼:

(config)#ip http authentication local

(config)#username cisco privilege 15 password 0 cisco

4、關閉密碼明文顯示

(config)#service password-encryption

5、配置consol口密碼

(config)#line con 0

(config-line)#password XXX

(config-line)#login

(config-line)#exit

6、啟用三層交換機路由功能(如三層交換機有多個VLAN需要開啟此功能)

(config)#ip?routing?????? //啟用三層交換機的路由的功能

(config)#ip classless? ? ?//配置允許跨網段ping網關及(訪問交換機管理地址)

7、開啟/關閉telnet訪問

(config)#line vty 0 4

開啟:

switch(config-line)#password 你的密碼

switch(config-line)#login

關閉:

(config-line)#no password

(config-line)#exit

8、配置端口1 IP地址為192.168.1.2(1端口用于連接防火墻,防火墻IP 192.168.1.1)

Switch>enable

Switch#configure terminal

Switch(config)#interface?GigabitEthernet1/0/1

Switch(config-if)#no switchport? --啟用此端口三層交換機功能

Switch(config-if)#ip address 192.168.1.2 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#description XXX? --描述名XXX,只支持英文

9、配置vlan1 IP地址,用于ssh連接

(config)#interface vlan 1

(config-if)#ip address 10.0.0.1 255.255.255.0

(config-if)#no shutdown? --開啟端口

(config-if)#description XXX? --描述名XXX,只支持英文

(config-if)#exit? --退出

以上是三層交換機的設置方法,二層交換機如以下:

(config)#interface vlan 1

(config-if)#ip address 10.0.0.2 255.255.255.0?????? #設置telnet iP為10.0.0.2

10、配置二層對連三層的端口,設置為允許所有vlan通過

(config)#interface range fastEthernet 0/1

(config-if-range)#switchport mode trunk? ? ? ? ? ? ? #配置成trunk模式,允許多個vlan通過這個端口,交換機默認使用dot1q進行封裝

11、增加靜態路由,允許所有vlan到防火墻出口

(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1? ? ? ? ? ? #10.10.10.1為防火墻接口地址

 

三、創建VLAN 10 ? (vlan 1 設備自動生成,不能更改、刪除)

 

方法1:

# vlan database

(vlan)# vlan 10 name XXX

(vlan)#apple

方法2:

#configure terminal

(config)#vlan 10

(config-vlan)#name XXX

(config-vlan)#exit

 

四、Vlan配置

 

# configure terminal

(config-if)#interface vlan 10? --進入Vlan 10

(config-if)#ip address 192.168.10.254 255.255.255.0? --配置此Vlan網關地址為192.168.10.254

(config-if)#no shutdown? --開啟端口

(config-if)#description XXX? --描述名XXX,只支持英文

(config-if)#exit? --退出

 

五、添加Vlan到某個端口

 

#show run? --可查看到各個端口允許Vlan信息

#show ip int brief? --查看端口狀態

#show int f0/6(端口),? --查看端口6詳細信息

#configure terminal

(config)#interface range gigabitEthernet 0/16? --進入端口16

(config-if-rang)#no shutdown? --開啟端口

(config-if-rang)#switchport mode access? --將交換機端口轉換為ACCESS模式(一般不需要設置這個)

(config-if-rang)#switchport access vlan 10? --在16端口允許Vlan 10通過

(config-if-rang)#no switport access vlan 10? --刪除此端口的Vlan信息

(config-if-rang)#exit? --退出

 

六、單獨修改某個Vlan網關

 

(config-if)#interface vlan 10? --進入Vlan 10

(config-if)#ip address 192.168.10.254 255.255.255.0? --配置此Vlan網關地址為192.168.10.254

 

七、創建ACL規則

 

(config)#ip access-list extended swj(ACL規則名)

(config-ext-nacl)#deny ip 192.168.30.0 0.0.0.255 192.168.10.0 0.0.0.255

----拒絕vlan30的用戶訪問vlan10資源

  1. #show?running-config?interface?vlan?888????????-----查看vlan888對應acl規則名是哪個
  2. Building?configuration...
  3. Current?configuration?:?91?bytes
  4. !
  5. interface?Vlan888
  6. ?ip?address?201.123.123.254?255.255.255.0
  7. ?ip?access-group?BGS?in
  8. end

 

八、將ACL應用到 vlan10

 

(config)#interface vlan 10? --創建vlan10的SVI接口

(config-if)#ip access-group swj in? --將擴展ACL應用到vlan10的SVI接口下

 

九、ACL策略添加編輯

 

(config)#ip access-list extended BGS(ACL規則名)? --進入BGS

(config-ext-nacl)#91 permit ip host 201.123.116.230 192.168.10.0 0.0.0.255

--允許192.168.10.0網段訪問201.123.116.230

(config-ext-nacl)#92 permit ip host 201.123.116.230 host 201.123.123.233

--允許201.123.123.233訪問201.123.116.230

(config-ext-nacl)#100 deny ip 201.123.116.0 0.0.0.255 201.123.123.0 0.0.0.255

--禁止123網段訪問116網段

(config-ext-nacl)#no 10 permit host 201.123.123.233 host 201.123.119.34? --刪除編號為10的規則

 

十、重啟端口

 

(config)#interface gigabitEthernet 1/0/16? --進入端口16

(config-if)#shutdown? --先關閉端口

(config-if)#no shutdown? --在開啟端口

 

十一、保存

 

#copy run-configure start-configure

發表評論

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: